Slower TLS handshakes on logs.papertrailapp.com and logs6.papertrailapp.com
Incident Report for Papertrail
Resolved
Additional resources were added to the logs and logs6 endpoints and they have been stable for a week. We will continue to monitor, but do not expect any further customer impact from slow TLS handshakes.
Posted 8 months ago. Feb 14, 2019 - 14:14 PST
Monitoring
The logs and logs6 endpoints have been experiencing increased load recently, leading to slower TLS handshakes during peak periods.

UDP senders and plaintext TCP senders are not affected. Some TLS senders may see increased queueing and delays during peak times, depending on how often they reconnect to Papertrail. Some senders could even drop messages, in the absence of client-side queueing.

We're adding capacity to handle the increased load, but it may be a few days before that is online. In the meantime, anyone affected by the slower TLS handshakes is advised to create a new destination, which will be allocated on a different cluster.
Posted 9 months ago. Jan 28, 2019 - 15:57 PST
This incident affected: Log Collection.