Password Reset and New-user Invitation Email Delays
Incident Report for Papertrail
Resolved
Password reset and new-user invitations should now arrive in inboxes. As a reminder, if the reset or invite was generated within the last couple hours but did not arrive, it will need to be re-sent.

If it still doesn't arrive, Papertrail Support (support@papertrailapp.com) will be happy to assist.
Posted 14 days ago. Nov 30, 2018 - 16:19 PST
Identified
We've identified the cause of the delay. Any password resets or new-user invitations that were attempted in the last 2 hours, if they have not been received, please retry.
Posted 14 days ago. Nov 30, 2018 - 16:10 PST
Investigating
Engineering is investigating a delay in password reset and new-user invitation emails.
Posted 14 days ago. Nov 30, 2018 - 16:01 PST
This incident affected: Website.