Email Delivery Issue
Incident Report for Papertrail
Resolved
This incident has been resolved.
Posted Feb 04, 2023 - 14:16 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 04, 2023 - 13:57 PST
Identified
We have identified an issue with our email provider.
All email communications (account signup, alerts with mail notification) are currently affected.
Posted Feb 04, 2023 - 12:24 PST
Investigating
We are currently investigating this issue.
Posted Feb 04, 2023 - 11:07 PST
This incident affected: Search Alerts.