We have noticed an escalated error rate from the website
Incident Report for Papertrail
Resolved
This incident has been resolved.
Posted 2 months ago. Apr 06, 2019 - 07:39 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 2 months ago. Apr 06, 2019 - 07:31 PDT
Investigating
We are currently investigating this issue.
Posted 2 months ago. Apr 06, 2019 - 07:06 PDT
This incident affected: Website.