Papertrail is experiencing 500s
Incident Report for Papertrail
Resolved
This incident has been resolved.
Posted Jul 24, 2019 - 17:52 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 24, 2019 - 17:50 PDT
Investigating
We are currently investigating this issue.
Posted Jul 24, 2019 - 17:23 PDT
This incident affected: Website and Log Search.