TLS 1.0 and 1.1 Deprecation Test Run
Scheduled Maintenance Report for Papertrail
Completed
The scheduled maintenance has been completed.
Posted 3 months ago. May 08, 2018 - 15:00 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 3 months ago. May 08, 2018 - 14:00 PDT
Scheduled
For one hour on May 8th at 21:00 UTC, we will disable TLS 1.0 and TLS 1.1 support for the Papertrail website and API. This is in preparation to permanently remove support for these deprecated security protocols. During this window, if your browser or client are no longer able to interact with papertrailapp.com or the Papertrail API, make sure it supports TLS 1.2.

The following minimum browser versions support TLS 1.2:

Microsft Internet Exporer 11
Microsoft Edge (all)
Firefox 27
Chrome 30
Safari 7.0 (OS X 10.9)
Mobile Safari 5.1 (iOS 5.1)
Opera 17

Any command line client or library that uses SSL libraries from the last few years are all likely to be supported. If you're unsure, attempt to connect to the API or browse papertrailapp.com during this window to confirm.

We understand that the vast majority of HTTPS traffic already comes from clients that support TLS 1.2, but a very small percentage may be affected by this deprecation. After the hour is up, support for TLS 1.0 and 1.1 will be turned back on, but only temporarily, giving users time to make the necessary updates. On May 14th, we we disable TLS 1.0 and 1.1 permanently. A notification will be pushed out before that takes place.

If you have any questions or need assistance in confirming support for your browsers or clients, contact Papertrail Support at support@papertrailapp.com.
Posted 4 months ago. May 01, 2018 - 15:36 PDT
This scheduled maintenance affected: Website.